Don’t upgrade Kodi to v17 on FireTV

If you use DTS pass-through, don’t upgrade Kodi to version 17.0 (Krypton) on FireTV. The new version of Kodi needs a newer version of Android (version 6.0 / Marshmallow) or later to support DTS pass-through.

If you’ve already upgraded, you will need to re-install version Kodi 16.1. You may have to fully uninstall Kodi 17, before you can reinstall the old version.

Author: Musaul Karim

Software Engineer, Hobbyist Photographer, and a bit of a gadget geek.

Leave a Reply

Your email address will not be published. Required fields are marked *